产品
产品中心
< 返回主菜单
产品

交换机

交换机所有产品
< 返回产品
交换机
查看交换机首页 >

无线

无线所有产品
< 返回产品
无线
查看无线首页 >

云桌面

云桌面所有产品
< 返回产品
云桌面
查看云桌面首页 >

安全

安全所有产品
< 返回产品
安全
查看安全首页 >
产品中心首页 >
行业
行业中心
< 返回主菜单
行业
行业中心首页 >

【RSR】RSR如何实施指导QOS

发布时间:2013-09-12
点击量:2647

功能介绍:

QOS的实施,不仅仅指示队列机制的应用。他包括了”流量分类和标记“,”拥塞管理(队列机制)“,”流量整型“的有机结合。

对于CBWFQ和LLQ的实施,特殊注意,要与GTS配合使用。

注意:锐捷队列机制有默认的default队列,无需配置;所有未被定义到的数据流默认属于default队列;网络拥塞时default队列默认低优先级处理,占用剩余未分配的带宽;类似于思科的default队列;区别在于,思科的default队列需要配置,而锐捷的不需要配置;

一、组网需求

RSR-A作为某金融接入路由器,GI0/0 为出接口,租用MSTP专线,带宽为 2M,需要对以下流分类采用LLQ机制进行带宽保障,并对相应的流量进行标记,以便于上级设备使用标记进行控制:

1、对于视频监控,需要确保低延时,并保障500Kbps带宽,设置IP优先级为5

2、对于生产网段流量,保障 600Kbps带宽,设置IP优先级为4

3、对于办公网段流量,保障 800Kbps带宽,设置IP优先级为2 

二、组网拓扑

     

三、配置要点

1、进行流分类标记

2、配置LLQ队列策略

1)配置接口可用带宽比例

2)用ACL进行流量分类

3)定义类别映射表,class-map关联ACL

4)定义策略映射表,关联class-map,并对class-map对应分类打标并QOS策略

5)在接口调用policy-map

3、配置GTS

 

四、配置步骤

1、进行流分类标记

流分类标记可以在入口方向标记,也可以在出方向标记;可以使用”class-map“”CAR“”PBR“三种方式之一进行打标。

但是,在这种使用LLQ或着CBWFQ的场景中,推荐的方式是使用”class-map“方式,并且在配置LLQ或CBWFQ时同步进行打标,简化了配置

下文将以class-map的方式举例,如果需要使用其他方式打标,可以参考”流量分类和标记“章节(典型配置--->QOS--->流量分类和打标)

2、配置LLQ队列策略

1)配置接口可用带宽比例:

RSR-A(config)#interface GigabitEthernet 0/0 

RSR-A(config-GigabitEthernet 0/0)#max-reserved-bandwidth 95

//默认情况下,分配给所有类别的带宽总和不能超过接口可用带宽的75%。余下的25%用于传输控制数据流和路由选择数据流。在实际使用中,一般推荐配置为95-99,充分利用链路带宽的同时,确保预留部分带宽给路由协商等控制报文使用。

2)用ACL进行流量分类

RSR-A(config)#access-list 100 permit ip 192.168.1.0 0.0.0.255 any     //定义视频网段数据流

RSR-A(config)#access-list 101 permit ip 172.16.1.0 0.0.0.255 any       //定义生产网段数据流

RSR-A(config)#access-list 102 permit ip 10.1.1.0 0.0.0.255 any           //定义办公网段数据流

3)定义类别映射表,class-map关联ACL

RSR-A(config)#class-map SP             //定义视频流分类,注意,这里的命名区分大小写

RSR-A(config-cmap)#match access-group 100

RSR-A(config-cmap)#class-map SC      //定义生产流分类

RSR-A(config-cmap)#match access-group 101

RSR-A(config-cmap)#class-map BG      //定义办公流分类

RSR-A(config-cmap)#match access-group 102

4定义策略映射表关联class-map并对class-map对应分类打标并QOS策略

RSR-A(config)#policy-map ruijie

RSR-A(config-pmap)#class SP

RSR-A(config-pmap-c)#priority 500          //定义视频流分类带宽保障500Kbps,priority 是LLQ的带宽保障关键字。这里的单位是kbps

RSR-A(config-pmap-c)#set ip precedence 5 //设置IP优先级,可以在对流分类进行带宽保障的同时进行打标

RSR-A(config-pmap)#class SC

RSR-A(config-pmap-c)#bandwidth 600     //定义生产流分类带宽保障800Kbps,bandwidth 是CBWFQ的带宽保障关键字。这里的单位是kbps

RSR-A(config-pmap-c)#set ip precedence 4 //设置IP优先级,可以在对流分类进行带宽保障的同时进行打标

RSR-A(config-pmap-c)#class BG

RSR-A(config-pmap-c)#bandwidth 800    //还可以使用带宽比例来配置 bandwidth percent 50

RSR-A(config-pmap-c)#set ip precedence 2   //设置IP优先级,可以在对流分类进行带宽保障的同时进行打标

5)在接口调用policy-map

RSR-A(config)#interface GigabitEthernet 0/0 

RSR-A(config-GigabitEthernet 0/0)#service-policy output ruijie       //队列调度,只能应用在接口出方向

 3、配置GTS

RSR-A(config-GigabitEthernet 0/0)#traffic-shape rate 1900000

//技巧:

1、配置GTS的目的:我们使用的是千兆接口和运营商MSTP互联,那么该GI0/0接口为千兆全双工模式。队列机制生效的前提是感知到了接口拥塞。很明显,这里千兆接口是不可能拥塞的,报文都在运营商那端被丢弃。而这里GTS除了起到整型作用,还为QOS模块提供了一个拥塞的参考带宽,即,超过2Mbps就拥塞了,队列机制要开始按需调度了。

2、这里运营商提供的MSTP链路带宽是2Mbps,可为什么配置1.9Mbps?因为,运营商提供的带宽不一定达到2M,通常也略有水分。但就是一点点的水分会影响QOS的效果。比如,运营商宣称2Mbps,实际只有1.9Mbps,GTS配置的是2Mbps,导致的结果是,在达到1.99Mbps流量是,队列机制还未生效,但已经有0.09Mbps的流量被运营商丢弃了,对于优先级高的报文也是等比例丢弃,无法确保QOS效果。

3、经验值:

以太链路:配置为运营商提供带宽的95%

ATM链路:配置为运营商提供带宽的80% 。说明:由于QOS是IP层功能,数据进入ATM接口封装为信元后,报文开销会而外增大许多,所以,如果ATM带宽10Mbps时,GTS限制为8Mbps,加上ATM信元开销就接近10Mbps了。

 

 

五、配置验证

1、通过show policy-map interface 具体接口,确认接口LLQ策略情况。

2、通过sho queue interface gigabitEthernet 0/0具体接口,确认接口GTS和队列调用情况。

 

 

 

 

 

 

相关产品

返回顶部

请选择服务项目
关闭咨询页
售前咨询 售前咨询
售前咨询
售后服务 售后服务
售后服务
意见反馈 意见反馈
意见反馈
更多联系方式