【RSR】RSR如何配置CBWFQ

发布时间: 2013-09-12 点击量:585 打印 字体:

功能介绍:

CBWFQ拓展了标准WFQ的功能,支持用户自定义的数据流类别。可以根据多种条件来定义数据流类别。(协议/ACL/输入接口)

CBWFQ可以根据策略,对每个类别指定最低带宽保障值或最低带宽保障比例。

CBWFQ和LLQ的区别:

  1. CBWFQ每个队列是加权公平的,可以保障每个队列的最低带宽,但无法确保时延;
  2. LLQ队列是在CBWFQ基础上,增加一个PQ队列,即,LLQ=CBWFQ+PQ。对于对延时敏感的业务,比如VOIP,可以放到PQ队列,得到低延时保障。

注意:锐捷队列机制有默认的default队列,无需配置;所有未被定义到的数据流默认属于default队列;网络拥塞时default队列默认低优先级处理,占用剩余未分配的带宽;类似于思科的default队列;区别在于,思科的default队列需要配置,而锐捷的不需要配置;

一、组网需求

对于RSR-A路由器,serial2/1为出接口,带宽为 2M,需要对以下流分类进行带宽保障:

1、对于生产网段流量,保障 800Kbps带宽

2、对于办公网段流量,保障 1000Kbps带宽

二、组网拓扑

     

三、配置要点

1、配置接口可用带宽比例

2、用ACL进行流量分类

3、定义类别映射表,class-map关联ACL

Router(config)#class-map ?

  WORD       class-map name

  match-all  Logical-AND all matching statements under this classmap-----------match的条件是and(逻辑与)的关系

  match-any  Logical-OR all matching statements under this classmap-----------match的条件是or(逻辑或)的关系

Router(config)#class-map ruijie -----------------如果只写名字,不写match-all或match-any,默认是match-all的关系

4、定义策略映射表,关联class-map,并对class-map进行带宽保障策略。

5、在接口调用policy-map

四、配置步骤

1、配置接口可用带宽比例

RSR-A(config)#interface Serial 2/1

RSR-A(config-if - Serial 2/1)#max-reserved-bandwidth 95

//默认情况下,分配给所有类别的带宽总和不能超过接口可用带宽的75%。余下的25%用于传输控制数据流和路由选择数据流。在实际使用中,一般推荐配置为95-99,充分利用链路带宽的同时,确保预留部分带宽给路由协商等控制报文使用。

2、用ACL进行流量分类

RSR-A(config)#access-list 100 permit ip 192.168.1.0 0.0.0.255 any     //定义生产网段数据流

RSR-A(config)#access-list 101 permit ip 172.16.1.0 0.0.0.255 any       //定义办公网段数据流

3、定义类别映射表,class-map关联ACL

RSR-A(config)#class-map SC             //定义生产流分类,注意,这里的命名区分大小写

RSR-A(config-cmap)#match access-group 100

RSR-A(config-cmap)#class-map BG      //定义办公流分类

RSR-A(config-cmap)#match access-group 101

4、定义策略映射表关联class-map并对class-map对应分类打标

RSR-A(config)#policy-map ruijie

RSR-A(config-pmap)#class SC

RSR-A(config-pmap-c)#bandwidth 800     //定义生产流分类带宽保障800Kbps,bandwidth 是CBWFQ的带宽保障关键字。这里的单位是kbps

RSR-A(config-pmap-c)#class BG

RSR-A(config-pmap-c)#bandwidth 1000    //还可以使用带宽比例来配置 bandwidth percent 50

5、在接口调用policy-map

RSR-A(config)#interface Serial 2/1

RSR-A(config-if - Serial 2/1)#service-policy output ruijie       //队列调度,只能应用在接口出方向

 

五、配置验证

1、通过show policy-map interface Serial 2/1 具体接口,确认接口CBWFQ策略情况。

 

 

 

 

 

00 分享 纠错
相关条目